use strict;
my $str = 'AB cµÀ´\'(-+=0123¢-1-"';
my $regex = qr/[^/[A-Za-z\d\u00C0-\u00D6\u00D8-\u00F6\u00F8-\u00FF\u0100-\u0148\u014A-\u024F\u1E02-\u1EF3\u2C60-\u2C7F\uA720-\uA7FF\uAB30-\uAB6F \$\,\.\(\)\?\xBF\xA1\!\%\#\@\xA2]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}