import re
regex = re.compile(r"[^/[A-Za-z\d\u00C0-\u00D6\u00D8-\u00F6\u00F8-\u00FF\u0100-\u0148\u014A-\u024F\u1E02-\u1EF3\u2C60-\u2C7F\uA720-\uA7FF\uAB30-\uAB6F \$\,\.\(\)\?\xBF\xA1\!\%\#\@\xA2]*")
test_str = "AB cµÀ´'(-+=0123¢-1-\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")