const regex = /[^/[A-Za-z\d\u00C0-\u00D6\u00D8-\u00F6\u00F8-\u00FF\u0100-\u0148\u014A-\u024F\u1E02-\u1EF3\u2C60-\u2C7F\uA720-\uA7FF\uAB30-\uAB6F \$\,\.\(\)\?\xBF\xA1\!\%\#\@\xA2]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\/[A-Za-z\\d\\u00C0-\\u00D6\\u00D8-\\u00F6\\u00F8-\\u00FF\\u0100-\\u0148\\u014A-\\u024F\\u1E02-\\u1EF3\\u2C60-\\u2C7F\\uA720-\\uA7FF\\uAB30-\\uAB6F \\$\\,\\.\\(\\)\\?\\xBF\\xA1\\!\\%\\#\\@\\xA2]*', 'g')
const str = `AB cµÀ´'(-+=0123¢-1-"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}