import Foundation
let pattern = ##"[^/[A-Za-z\d\u00C0-\u00D6\u00D8-\u00F6\u00F8-\u00FF\u0100-\u0148\u014A-\u024F\u1E02-\u1EF3\u2C60-\u2C7F\uA720-\uA7FF\uAB30-\uAB6F \$\,\.\(\)\?\xBF\xA1\!\%\#\@\xA2]*"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"AB cµÀ´'(-+=0123¢-1-""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)