re = /[^\/[A-Za-z\d\u00C0-\u00D6\u00D8-\u00F6\u00F8-\u00FF\u0100-\u0148\u014A-\u024F\u1E02-\u1EF3\u2C60-\u2C7F\uA720-\uA7FF\uAB30-\uAB6F \$\,\.\(\)\?\xBF\xA1\!\%\#\@\xA2]*/
str = 'AB cµÀ´\'(-+=0123¢-1-"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end