use strict;
my $str = 'Frankfurt Izmir XQ 971 SunEco A 13/03/2016 14:55 AINT9 HK 30
Izmir Trabzon XQ 9270 SunEco S 13/03/2016 20:10 SADDOND HK 30
Trabzon Antalya XQ 7619 SunEco S 31/03/2016 12:00 SADDOND HK 30
Antalya Frankfurt XQ 140 SunEco Z 31/03/2016 15:00 ZINT8 HK 30';
my $regex = qr/([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\s([0-9]+)\s([A-Za-z]+)(\s+)([A-Z])\s([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4}\s)([0-9]{1,2}):([0-9]{1,2})\s/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}