import Foundation
let pattern = #"([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\s([0-9]+)\s([A-Za-z]+)(\s+)([A-Z])\s([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4}\s)([0-9]{1,2}):([0-9]{1,2})\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Frankfurt Izmir XQ 971 SunEco A 13/03/2016 14:55 AINT9 HK 30
Izmir Trabzon XQ 9270 SunEco S 13/03/2016 20:10 SADDOND HK 30
Trabzon Antalya XQ 7619 SunEco S 31/03/2016 12:00 SADDOND HK 30
Antalya Frankfurt XQ 140 SunEco Z 31/03/2016 15:00 ZINT8 HK 30
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)