import re
regex = re.compile(r"([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\s([0-9]+)\s([A-Za-z]+)(\s+)([A-Z])\s([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4}\s)([0-9]{1,2}):([0-9]{1,2})\s")
test_str = ("Frankfurt Izmir XQ 971 SunEco A 13/03/2016 14:55 AINT9 HK 30 \n"
"Izmir Trabzon XQ 9270 SunEco S 13/03/2016 20:10 SADDOND HK 30 \n"
"Trabzon Antalya XQ 7619 SunEco S 31/03/2016 12:00 SADDOND HK 30 \n"
"Antalya Frankfurt XQ 140 SunEco Z 31/03/2016 15:00 ZINT8 HK 30")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")