import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:<?+\\$(\\d+))?-?(?:>?(\\d+)k)?";
final String string = "<$10k\n"
+ "$10-20k\n"
+ "$20-30k\n"
+ "$30-40k\n"
+ "$40-50k\n"
+ "$50-75k\n"
+ "$75-100k\n"
+ "$100-150k\n"
+ ">150k\n"
+ "Don't know/refused\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}