import re
regex = re.compile(r"^(?:<?+\$(\d+))?-?(?:>?(\d+)k)?", flags=re.MULTILINE)
test_str = ("<$10k\n"
"$10-20k\n"
"$20-30k\n"
"$30-40k\n"
"$40-50k\n"
"$50-75k\n"
"$75-100k\n"
"$100-150k\n"
">150k\n"
"Don't know/refused\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")