const regex = /^(?:<?+\$(\d+))?-?(?:>?(\d+)k)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:<?+\\$(\\d+))?-?(?:>?(\\d+)k)?', 'gm')
const str = `<\$10k
\$10-20k
\$20-30k
\$30-40k
\$40-50k
\$50-75k
\$75-100k
\$100-150k
>150k
Don't know/refused
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}