re = /^(?:<?+\$(\d+))?-?(?:>?(\d+)k)?/m
str = '<$10k
$10-20k
$20-30k
$30-40k
$40-50k
$50-75k
$75-100k
$100-150k
>150k
Don\'t know/refused
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end