using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!global\.css$).)*\.css$";
string input = @"test.test.css
test.css
test.global.css
test.css
test.test.css
test.global.test.css
test.global.test.test.global.css
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}