re = /^(?:(?!global\.css$).)*\.css$/m
str = 'test.test.css
test.css
test.global.css
test.css
test.test.css
test.global.test.css
test.global.test.test.global.css
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end