import re
regex = re.compile(r"^(?:(?!global\.css$).)*\.css$", flags=re.MULTILINE)
test_str = ("test.test.css\n"
"test.css\n"
"test.global.css\n"
"test.css\n"
"test.test.css\n"
"test.global.test.css\n"
"test.global.test.test.global.css\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")