$re = '/^(?:(?!global\.css$).)*\.css$/m';
$str = 'test.test.css
test.css
test.global.css
test.css
test.test.css
test.global.test.css
test.global.test.test.global.css
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);