import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!global\\.css$).)*\\.css$";
final String string = "test.test.css\n"
+ "test.css\n"
+ "test.global.css\n"
+ "test.css\n"
+ "test.test.css\n"
+ "test.global.test.css\n"
+ "test.global.test.test.global.css\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}