# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div class="dotted-highlight">\s*+(?!<strong>[^<]*<\/strong>\s*<ul>)([^\s<]*+(?:(?!\s*<ul>)[\s<]+[^\s<]*)*+)\s*<ul>/<div class="dotted-highlight"><strong>$1<\/strong><ul>/si;t' <<< "<div class=\"dotted-highlight\"> <strong>So, to sum up your own appearance:</strong>
<ul>
<div class=\"dotted-highlight\">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>"