$re = '~<div class="dotted-highlight">\s*+(?!<strong>[^<]*</strong>\s*<ul>)([^\s<]*+(?:(?!\s*<ul>)[\s<]+[^\s<]*)*+)\s*<ul>~si';
$str = '<div class="dotted-highlight"> <strong>So, to sum up your own appearance:</strong>
<ul>
<div class="dotted-highlight">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>';
$subst = "<div class=\"dotted-highlight\"><strong>$1</strong><ul>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;