#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?si)<div class="dotted-highlight">\s*+(?!<strong>[^<]*</strong>\s*<ul>)([^\s<]*+(?:(?!\s*<ul>)[\s<]+[^\s<]*)*+)\s*<ul>"
Local $sString = "<div class="dotted-highlight"> <strong>So, to sum up your own appearance:</strong>" & @CRLF & _
"<ul>" & @CRLF & _
"<div class="dotted-highlight">So, to sum up your own appearance:" & @CRLF & _
"<ul>" & @CRLF & _
"<li>Your hair must be neat and tidy.</li>"
Local $sSubst = "<div class="dotted-highlight"><strong>$1</strong><ul>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)