using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""dotted-highlight"">\s*+(?!<strong>[^<]*</strong>\s*<ul>)([^\s<]*+(?:(?!\s*<ul>)[\s<]+[^\s<]*)*+)\s*<ul>";
string substitution = @"<div class=""dotted-highlight""><strong>$1</strong><ul>";
string input = @"<div class=""dotted-highlight""> <strong>So, to sum up your own appearance:</strong>
<ul>
<div class=""dotted-highlight"">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}