import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"dotted-highlight\">\\s*+(?!<strong>[^<]*</strong>\\s*<ul>)([^\\s<]*+(?:(?!\\s*<ul>)[\\s<]+[^\\s<]*)*+)\\s*<ul>";
final String string = "<div class=\"dotted-highlight\"> <strong>So, to sum up your own appearance:</strong>\n"
+ "<ul>\n"
+ "<div class=\"dotted-highlight\">So, to sum up your own appearance:\n"
+ "<ul>\n"
+ "<li>Your hair must be neat and tidy.</li>";
final String subst = "<div class=\"dotted-highlight\"><strong>$1</strong><ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}