use strict;
my $str = '<div class="dotted-highlight"> <strong>So, to sum up your own appearance:</strong>
<ul>
<div class="dotted-highlight">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>';
my $regex = qr~<div class="dotted-highlight">\s*+(?!<strong>[^<]*</strong>\s*<ul>)([^\s<]*+(?:(?!\s*<ul>)[\s<]+[^\s<]*)*+)\s*<ul>~sip;
my $subst = '<div class="dotted-highlight"><strong>$1</strong><ul>';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";