#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.){1,3}[a-z0-9](?:[a-z0-9-]*[a-z0-9])?$"
Local $sString = "wiliam@hotmail.com" & @CRLF & _
"wiliam.ferraciolli@hotmail.com" & @CRLF & _
"wiliam@hotmail.co.uk" & @CRLF & _
"wiliam.ferraciolli@hotmail.co.uk" & @CRLF & _
"wiliam_ferraciolli@hotmail.co.uk" & @CRLF & _
"wiliam'ferraciolli@hotmail.co.uk" & @CRLF & _
"wiliam334-1@mydomain.co.uk.me" & @CRLF & _
"" & @CRLF & _
"wiliam.ferraciolli@hotmail.com.dodge.too.many" & @CRLF & _
"hwiliam@hotmail.com.otherdomain.uk.dodge" & @CRLF & _
"wiliam.ferraciolli@hotmail.com.com.com.com" & @CRLF & _
"wiliam.hotmail.com" & @CRLF & _
"wiliam..ferraciolli@hotmail.com" & @CRLF & _
"wiliam%ferraciolli.@hotmail.com" & @CRLF & _
"wiliam$ferraciolli.@hotmail.com" & @CRLF & _
"wiliam/ferraciolli.@hotmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")