// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.){1,3}[a-z0-9](?:[a-z0-9-]*[a-z0-9])?$").unwrap();
let string = "wiliam@hotmail.com
wiliam.ferraciolli@hotmail.com
wiliam@hotmail.co.uk
wiliam.ferraciolli@hotmail.co.uk
wiliam_ferraciolli@hotmail.co.uk
wiliam'ferraciolli@hotmail.co.uk
wiliam334-1@mydomain.co.uk.me
wiliam.ferraciolli@hotmail.com.dodge.too.many
hwiliam@hotmail.com.otherdomain.uk.dodge
wiliam.ferraciolli@hotmail.com.com.com.com
wiliam.hotmail.com
wiliam..ferraciolli@hotmail.com
wiliam%ferraciolli.@hotmail.com
wiliam$ferraciolli.@hotmail.com
wiliam/ferraciolli.@hotmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}