package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.){1,3}[a-z0-9](?:[a-z0-9-]*[a-z0-9])?$`)
var str = `wiliam@hotmail.com
wiliam.ferraciolli@hotmail.com
wiliam@hotmail.co.uk
wiliam.ferraciolli@hotmail.co.uk
wiliam_ferraciolli@hotmail.co.uk
wiliam'ferraciolli@hotmail.co.uk
wiliam334-1@mydomain.co.uk.me
wiliam.ferraciolli@hotmail.com.dodge.too.many
hwiliam@hotmail.com.otherdomain.uk.dodge
wiliam.ferraciolli@hotmail.com.com.com.com
wiliam.hotmail.com
wiliam..ferraciolli@hotmail.com
wiliam%ferraciolli.@hotmail.com
wiliam$ferraciolli.@hotmail.com
wiliam/ferraciolli.@hotmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}