use strict;
my $str = 'wiliam@hotmail.com
wiliam.ferraciolli@hotmail.com
wiliam@hotmail.co.uk
wiliam.ferraciolli@hotmail.co.uk
wiliam_ferraciolli@hotmail.co.uk
wiliam\'ferraciolli@hotmail.co.uk
wiliam334-1@mydomain.co.uk.me
wiliam.ferraciolli@hotmail.com.dodge.too.many
hwiliam@hotmail.com.otherdomain.uk.dodge
wiliam.ferraciolli@hotmail.com.com.com.com
wiliam.hotmail.com
wiliam..ferraciolli@hotmail.com
wiliam%ferraciolli.@hotmail.com
wiliam$ferraciolli.@hotmail.com
wiliam/ferraciolli.@hotmail.com';
my $regex = qr;^[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.){1,3}[a-z0-9](?:[a-z0-9-]*[a-z0-9])?$;mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}