# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.){1,3}[a-z0-9](?:[a-z0-9-]*[a-z0-9])?$"
test_str = ("wiliam@hotmail.com\n"
"wiliam.ferraciolli@hotmail.com\n"
"wiliam@hotmail.co.uk\n"
"wiliam.ferraciolli@hotmail.co.uk\n"
"wiliam_ferraciolli@hotmail.co.uk\n"
"wiliam'ferraciolli@hotmail.co.uk\n"
"wiliam334-1@mydomain.co.uk.me\n\n"
"wiliam.ferraciolli@hotmail.com.dodge.too.many\n"
"hwiliam@hotmail.com.otherdomain.uk.dodge\n"
"wiliam.ferraciolli@hotmail.com.com.com.com\n"
"wiliam.hotmail.com\n"
"wiliam..ferraciolli@hotmail.com\n"
"wiliam%ferraciolli.@hotmail.com\n"
"wiliam$ferraciolli.@hotmail.com\n"
"wiliam/ferraciolli.@hotmail.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.