using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\blevel-0-\d*)";
string input = @"level-0-0
level-0-1
level-0-2
level-0-3
level-0-4
level-0-5
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}