re = /(\blevel-0-\d*)/
str = 'level-0-0
level-0-1
level-0-2
level-0-3
level-0-4
level-0-5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end