$re = '/(\blevel-0-\d*)/';
$str = 'level-0-0
level-0-1
level-0-2
level-0-3
level-0-4
level-0-5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);