const regex = /(\blevel-0-\d*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\blevel-0-\\d*)', 'g')
const str = `level-0-0
level-0-1
level-0-2
level-0-3
level-0-4
level-0-5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}