import re
regex = re.compile(r"(\blevel-0-\d*)")
test_str = ("level-0-0\n"
"level-0-1\n"
"level-0-2\n"
"level-0-3\n"
"level-0-4\n"
"level-0-5\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")