import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\blevel-0-\\d*)";
final String string = "level-0-0\n"
+ "level-0-1\n"
+ "level-0-2\n"
+ "level-0-3\n"
+ "level-0-4\n"
+ "level-0-5\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}