#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/[A-Z]?[a-z]{1,3}[0-9]?\.exe$"
Local $sString = "hxxp://mnmassagetherapy[.]com/wp-content/uploads/2016/04/lib.exe" & @CRLF & _
"hxxp://seed-bc[.]com/juop4/plwr/mklo/rbn/jan2.exe" & @CRLF & _
"hxxp://15.204.49[.]148/files/Had.exe" & @CRLF & _
"hxxp://hugo.topteamlife[.]com/order/tuc5.exe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")