import Foundation
let pattern = #"\/[A-Z]?[a-z]{1,3}[0-9]?\.exe$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
hxxp://mnmassagetherapy[.]com/wp-content/uploads/2016/04/lib.exe
hxxp://seed-bc[.]com/juop4/plwr/mklo/rbn/jan2.exe
hxxp://15.204.49[.]148/files/Had.exe
hxxp://hugo.topteamlife[.]com/order/tuc5.exe
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)