import re
regex = re.compile(r"\/[A-Z]?[a-z]{1,3}[0-9]?\.exe$", flags=re.MULTILINE)
test_str = ("hxxp://mnmassagetherapy[.]com/wp-content/uploads/2016/04/lib.exe\n"
"hxxp://seed-bc[.]com/juop4/plwr/mklo/rbn/jan2.exe\n"
"hxxp://15.204.49[.]148/files/Had.exe\n"
"hxxp://hugo.topteamlife[.]com/order/tuc5.exe")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")