using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/[A-Z]?[a-z]{1,3}[0-9]?\.exe$";
string input = @"hxxp://mnmassagetherapy[.]com/wp-content/uploads/2016/04/lib.exe
hxxp://seed-bc[.]com/juop4/plwr/mklo/rbn/jan2.exe
hxxp://15.204.49[.]148/files/Had.exe
hxxp://hugo.topteamlife[.]com/order/tuc5.exe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}