package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/[A-Z]?[a-z]{1,3}[0-9]?\.exe$`)
var str = `hxxp://mnmassagetherapy[.]com/wp-content/uploads/2016/04/lib.exe
hxxp://seed-bc[.]com/juop4/plwr/mklo/rbn/jan2.exe
hxxp://15.204.49[.]148/files/Had.exe
hxxp://hugo.topteamlife[.]com/order/tuc5.exe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}