#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([A-Za-z0-9' -]+)|([$€]\d+([.,]\d{2})?))$"
Local $sString = "Awesome 123 " & @CRLF & _
"Cool " & @CRLF & _
"t-shirt" & @CRLF & _
"Great " & @CRLF & _
"here." & @CRLF & _
"I'm good " & @CRLF & _
"$1.00" & @CRLF & _
"€5.50" & @CRLF & _
"$4" & @CRLF & _
"450" & @CRLF & _
"45.55" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")