re = /^(([A-Za-z0-9' -]+)|([$€]\d+([.,]\d{2})?))$/m
str = 'Awesome 123
Cool
t-shirt
Great
here.
I\'m good
$1.00
€5.50
$4
450
45.55
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end