package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([A-Za-z0-9' -]+)|([$€]\d+([.,]\d{2})?))$`)
var str = `Awesome 123
Cool
t-shirt
Great
here.
I'm good
$1.00
€5.50
$4
450
45.55
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}