// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([A-Za-z0-9' -]+)|([$€]\d+([.,]\d{2})?))$").unwrap();
let string = "Awesome 123
Cool
t-shirt
Great
here.
I'm good
$1.00
€5.50
$4
450
45.55
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}