using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([A-Za-z0-9' -]+)|([$€]\d+([.,]\d{2})?))$";
string input = @"Awesome 123
Cool
t-shirt
Great
here.
I'm good
$1.00
€5.50
$4
450
45.55
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}