use strict;
my $str = 'Awesome 123
Cool
t-shirt
Great
here.
I\'m good
$1.00
€5.50
$4
450
45.55
';
my $regex = qr/^(([A-Za-z0-9' -]+)|([$€]\d+([.,]\d{2})?))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}