using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(\w+) )?order to (\w+) ([\-\d\.]+) (\w+) at ([\-\d\.]+|market) with ExDestination to (\w+) gets( fully| over)? filled(?: again)? (?:for ([\-\d\.]+)(?: contracts | shares )?)?at ([\-\d\.]+|market)";
string input = @"order to SELL 5 AAPL at market with ExDestination to ANY gets fully filled at market";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}