re = /^(?:(\w+) )?order to (\w+) ([\-\d\.]+) (\w+) at ([\-\d\.]+|market) with ExDestination to (\w+) gets( fully| over)? filled(?: again)? (?:for ([\-\d\.]+)(?: contracts | shares )?)?at ([\-\d\.]+|market)/
str = 'order to SELL 5 AAPL at market with ExDestination to ANY gets fully filled at market'
# Print the match result
str.match(re) do |match|
puts match.to_s
end