import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\w+) )?order to (\\w+) ([\\-\\d\\.]+) (\\w+) at ([\\-\\d\\.]+|market) with ExDestination to (\\w+) gets( fully| over)? filled(?: again)? (?:for ([\\-\\d\\.]+)(?: contracts | shares )?)?at ([\\-\\d\\.]+|market)";
final String string = "order to SELL 5 AAPL at market with ExDestination to ANY gets fully filled at market";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}