const regex = /^(?:(\w+) )?order to (\w+) ([\-\d\.]+) (\w+) at ([\-\d\.]+|market) with ExDestination to (\w+) gets( fully| over)? filled(?: again)? (?:for ([\-\d\.]+)(?: contracts | shares )?)?at ([\-\d\.]+|market)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\w+) )?order to (\\w+) ([\\-\\d\\.]+) (\\w+) at ([\\-\\d\\.]+|market) with ExDestination to (\\w+) gets( fully| over)? filled(?: again)? (?:for ([\\-\\d\\.]+)(?: contracts | shares )?)?at ([\\-\\d\\.]+|market)', '')
const str = `order to SELL 5 AAPL at market with ExDestination to ANY gets fully filled at market`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}