use strict;
my $str = 'order to SELL 5 AAPL at market with ExDestination to ANY gets fully filled at market';
my $regex = qr/^(?:(\w+) )?order to (\w+) ([\-\d\.]+) (\w+) at ([\-\d\.]+|market) with ExDestination to (\w+) gets( fully| over)? filled(?: again)? (?:for ([\-\d\.]+)(?: contracts | shares )?)?at ([\-\d\.]+|market)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}